The Ed-Fi Community and Tech Team were hard-at-work at the end of 2017, they release several important artifacts listed below. This news was also announced in real-time on the Ed-Fi Slack channel and we’d encourage you to join if you haven’t already.

ODS/API v3.0 – Technical Preview (a)

  • This is the long awaited preview release of the next major release of the ODS/API – aligned to the forthcoming Data Standard v3.0.
  • There are a host of new and valuable capabilities in this release – see v3.0 Tech Preview – Feature & Change Summary.
  • The Data Standard v3.0a RFC is also released, and implemented in the Tech Preview (a) release.
  • TechDocs info can be found here, and API documentation can be found here.

ODS/API v2.3.1

  • This is a maintenance release for the current ODS/API, that is backwards-compatible with previous ODS/API v2.x releases, and is aligned to the Data Standard v2.0.
  • We will release binaries for the Cloud ODS aligned to v2.3.1 January.
  • TechDocs info can be found here, and API documentation can be found here.

Release of Data Standard v3.0a RFC

2018 Draft Technical Roadmap

 

A valid question is: Which version should I be using?

Good question, I am glad you asked! Specific criteria may override this guidance, but in general:

Education Agencies:

  • SEA implementations of the Ed-Fi ODS/API:
    • Should start working with the v3.0 – Technical Preview, and plan for production deployment for the 2019/20 school year.
    • Consider upgrading to v2.3.1 for the 2018/19 school year if there are improvements or bug fixes of interest in the release notes.
  • LEA implementations of the Ed-Fi ODS/API:
    • If your implementation needs meets any of the following criteria, you should implement or upgrade to v2.3.1:
      • You are planning to go into production during the 1st half of 2018
      • Your implementation is dependent on being populated with data from Ed-Fi Certified SIS’s (certification against ODS/API v3.0 is anticipated to start sometime in the 2nd half of 2018).
      • Your implementation is based on Ed-Fi Core (with few or no extensions)
    • If you have a longer timeline and want to future proof your implementation, or do not have a dependency on data from certified SIS’s in 2018, then you should consider starting to work with the v3.0 Technical Preview.
  • Application vendors that integrate with the ODS/API:
    • If you are a certified SIS vendor, you should start to work with the v3.0 Technical Preview, to understand and plan for supporting agencies that move to this version, as well as updating your Ed-Fi certification.
    • v2.3.1 is backwards compatible with previous versions of the ODS/API, so your application should work unchanged.
    • v2.3.1 the reference platform for the Ed-Fi RFC 8 – Assessment Outcomes Management API.